高木のブログ

【Rails】chartkickを3系から4系に上げた時のメモ

2021/06/23

Railsでシンプルなグラフを扱うならchart-js-rails よりchartkickを使うべし - Qiitaの記事のようにRails 6にchartkick 3系を入れた前提

$ bundle update chartkick
$ bundle list | grep chartkick
  * chartkick (4.0.4)
$ yarn upgrade chartkick --latest
$ yarn upgrade chart.js --latest
$ yarn list --depth=0 | grep -e chart.js -e chartkick
├─ chart.js@3.2.1
├─ chartkick@4.0.4
app/javascript/packs/application.js
-require("chartkick")
-require("chart.js")
+require("chartkick/chart.js")

参考

ankane/chartkick: Create beautiful JavaScript charts with one line of Ruby


ytkg

Written by ytkg, Twitter, GitHub