高木のブログ

【RuboCop】Gemspec/RequiredRubyVersionの警告の対応

2021/03/11

問題

作っているGemのGitHub ActionsでRuboCopのジョブがコケた

switchbot.gemspec:15:32: C: Gemspec/RequiredRubyVersion: required_ruby_version (2.5, declared in switchbot.gemspec) and TargetRubyVersion (2.4, which may be specified in .rubocop.yml) should be equal.
  spec.required_ruby_version = Gem::Requirement.new('>= 2.5.0')

原因

GemがRuby 2.5以上を必要としているのに対し、RuboCopの対象Rubyバージョンが2.4を指定しているためコケていた
ローカルではなぜか警告が出ていなかった

解決方法

.rubocop.ymlにTargetRubyVersionの設定を追加して無事解決

.rubocop.yml
AllCops:
  TargetRubyVersion: 2.5

補足

RuboCopのデフォルトの設定項目は以下ファイルで確認することができる
https://github.com/rubocop/rubocop/blob/master/config/default.yml

参考

RuboCopの設定アレコレ - Qiita


ytkg

Written by ytkg, Twitter, GitHub